How to recover a router with wrong permissions on busybox

sezione dedicata ai sistemi operativi alternativi Open Source

How to recover a router with wrong permissions on busybox

Messaggio da leggereda root » 19/09/2016, 9:28

I wanted to disable the "reboot" command on my router since it has a bad bug that cause my router (Netgear DGND3700V1) to permanently hang during reboot process when invoked by "reboot" command.

I gave chmod 444 to "/bin/reboot" to try to disable it, but I did a disaster because I didn't mind that "/bin/reboot" is just a symbolic link to "/bin/busybox", so by giving chmod 444 to /bin/reboot I instead gave chmod 444 to all /bin/busybox :( :(

After that the system was unrecoverable, the router could not boot anymore.
I tried the failsafe procedure but there was no way to change permissions on busybox or launch any system command, all commands inside busybox were disabled, including chown, chmod, firstboot, ls, rm, ... etc.

I solved the problem in this way (after a sleepless night):

I downloaded the package busyboxyyy.ipk for my router on my PC
enabled web server on my PC ( and put the busyboxyyy.ipk in /var/www directory
accessed the router with the failsafe procedure (telnet and gave "mount_root" command
Fortunately I previously installed the full wget package (replacing wget of busybox), so I was able to download the busyboxyy.ipk form my pc:


then I gave the following command to reinstall busybox:

opkg install busyboxyyy.ipk --force-reinstall --force-downgrade

and then I was able to recover my router :)

P.S.: don't forget to install the full wget package, it might save your router :D
Avatar utente
Messaggi: 450
Iscritto il: 10/04/2012, 10:55
Località: Turin

Torna a OpenWRT

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti